Voice VLAN در سوئیچهای سیسکو

اکثر IP Phoneهای سیسکو دارای دو پورت اترنت یا به عبارتی یک سوئیچ داخلی سه پورت می‌باشند. یکی از این پورتها به سوئیچ وصل می‌شود. از پورت دیگر می‌توان برای اتصال کامپیوتر و یا هر وسیله دیگری به شبکه استفاده کرد. پورت سوم سوئیچ هم به صورت داخلی به خود تلفن متصل شده است.
در شکل زیر PC1 از طریق پورت IP phone به شبکه وصل شده است و IP phone نیز به سوئیچ متصل شده است.


در سوئیچهای سیسکو این امکان وجود دارد که ترافیک IP phone و وسیله متصل به آن (در اینجا PC1) را به صورت لایه دویی از هم تفکیک کرد و در VLANهای مختلفی قرار داد. انجام این کار دارای چندین مزیت است:
1- افزایش امنیت شبکه: امکان ارتباط کنترل شده بین سیستمها و IP hone از طریق قرار دادن آنها در وی لن های مختلف فراهم می‌شود.
2- مدیریت بهتر آدرسهای IP: برای سیستمها و IP phone می‌توان محدوده آدرسهای متفاوتی را درنظر گرفت.
3- راحتی کنترل ترافیک و اعمال مکانیزم‌های QOS: امکان اعمال آسانتر سیاستهای کنترل ترافیک به علت مجزا بودن شبکه سیستمها و IP phoneها فراهم می‌شود.

پیکربندی سوئچ سیسکو برای voice vlan

برای پیکربندی پورت سوئیچ باید به صورت زیر عمل کنید.

Switch#conf t
Switch(config)#vlan 30
Switch(config-vlan)#name DATA

Switch(config-vlan)#vlan 31
Switch(config-vlan)#name VOICE
Switch(config-vlan)#exit

Switch(config)#interface gigabitEthernet 1/0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 30
Switch(config-if)#switchport voice vlan 31

در اینجا پورت متصل به IP phone از نوع access تعریف شده و در VLAN شماره 30 قرار گرفته است. همچنین VLAN شماره 31 به عنوان voice vlan در نظر گرفته شده است. در این حالت ترافیک مربوط به PC در وی لن 30 و ترافیک مربوط به IP phone در 31 قرار خواهند داشت.
در واقع می‌توان گفت پورت بین سوئیچ و IP phone از نوع ترانک است! و سوئیچ موجود در IP phone روی ترافیک خود تگ وی لن voice را می‌زند و بر روی ترافیک PC تگی را وارد نمی‌کند.
نکته: IP phone از طریق پروتکل CDP متوجه می‌شود که از چه تگی برای ترافیک خود استفاده کند. (در اینجا تگ شماره 31)

بررسی تنظیمات انجام شده

برای بررسی تنظیمات انجام شده از فرمان show interfaces gigabitEthernet 1/0/1 switchport استفاده می‌کنیم. همانطور که مشاهده می‌کنید مد پورت مورد نظر به عنوان اکسس نمایش داده می‌شود. همچنین در خط 11 وی لن شماره 31 به عنوان voice vlan نمایش داده شده است.

Switch#show interfaces gigabitEthernet 1/0/1 switchport 
Name: Gig1/0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiated
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 30 (PC)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: 31
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: All
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none

دادن آدرس IP به PCها و تلفنها توسط DHCP Server

برای دادن آدرس IP به سیستمها و IP phoneها می‌توان از یک DHCP server استفاده کرد. امکان پیکربندی DHCP server بر روی سوئیچهای لایه 3، روتر و یا یک سرور ویندوزی یا لینوکسی وجود دارد.
ما برای این کار از یک روتر سیسکو استفاده کرده‌ایم. روتر سیسکو مانند شکل زیر به سوئیچ متصل شده است.

پورت بین سوئیچ و روتر ترانک تعریف شده است. وی لنهای شماره 30 و 31 بر روی این پورتت ترانک allowed هستند.

interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk

با توجه به اینکه قبلا در پستهای “پیکربندی DHCP Server در روتر میکروتیک” و “DHCP options و پیکربندی آنها در میکروتیک” درباره پروتکل DHCP و DHCP Optionها توضیحات لازم را داده‌ایم در اینجا آن توضیحات را تکرار نمی‌کنیم.

ip dhcp excluded-address 192.168.30.1 192.168.30.10
ip dhcp excluded-address 192.168.31.1 192.168.31.10
!
ip dhcp pool PHONE
 network 192.168.31.0 255.255.255.0
 default-router 192.168.31.1
 option 150 ip 192.168.31.1
 dns-server 192.168.30.5
ip dhcp pool PC
 network 192.168.30.0 255.255.255.0
 default-router 192.168.30.1
 dns-server 192.168.30.5

interface FastEthernet0/0.30
 description PCs
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
interface FastEthernet0/0.31
 description PHONEs
 encapsulation dot1Q 31
 ip address 192.168.31.1 255.255.255.0

بررسی عملکرد DHCP server

توسط فرمان show ip dhcp binding می‌توان بررسی کرد DHCP server آدرسی را اختصاص داده است یا خیر.

Router#show ip dhcp binding 
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
192.168.31.11    0001.64D1.8180           --                     Automatic
192.168.30.11    000A.417A.3B06           --                     Automatic

در مطلب بعدی تحت عنوان “پیکربندی CME در GNS3” به نحوه پیکربندی یک روتر سیسکو به عنوان IP PBX پرداخته‌ایم.

پاسخی بگذارید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *