Traffic Policing

برای محدود کردن پهنای باند در مسیریاب‌های سیسکو می‌توان از Traffic Policing توسط فرمان rate-limit در مد واسط (interface) یا زیر واسطی (Subinterface) که قرار است محدودیت بر روی آن اعمال شود استفاده کرد. فرمت کامل این دستور به صورت زیر است.البته قسمتهای داخل براکت اختیاری می‌باشند و از اکثر آنها معمولا مواقعی که نیازهای خاص کیفیت سرویس (Quality Of Service) وجود داشته باشد، استفاده می‌شود.

rate-limit {input | output} [dscp dscp-value] [access-group [rate-limit] acl-index] bps burst-normal burst-max conform-action conform-action exceed-action exceed-action

input یا output: جهتی را که rate-limit بر رو آن عمل می‌کند، مشخص می‌کنند. output برای محدود کردن دانلود کاربران روی یک واسط و input برای محدود کردن آپلود کاربران روی یک واسط کاربرد دارد.

access-group: اگر بخواهیم محدودیت را برای آدرسهای IP خاصی اعمال کنیم، می‌توانیم از access-group برای این کار استفاده کنیم. به عنوان مثال یک مشتری ممکن است دارای دو محدوده آدرس باشد و بخواهید محدودیتهای متفاوتی را برای هر یک از این دو محدوده در نظر بگیرید.

bps: در این قسمت باید نرخ متوسط (average rate) را بر حسب بیت بر ثانیه باید نوشت.

normal-burst و max-burst: اندازه burst نرمال و حداکثر burst را باید بر حسب بایت مشخص کرد.

conform-action: در قسمت conform-action عملی را که باید بر روی بسته های دارای شرایط ذکر شده انجام شود، مشخص کنید. معمولا در این قسمت transmit را انتخاب می‌کنید.

exceed-action: در قسمت exceed-action عملی را که باید بر روی بسته هایی که از نرخ ذکر شده تجاوز می‌کنند، مشخص کنید. معمولا در این قسمت drop را باید وارد کنید تا بسته هایی که از نرخ تجاوز می‌کنند دور ریخته شوند.

مثال 1

اگر بخواهیم بر روی یک sub interface سرعت 2 مگا بیت در ثانیه را برای دانلود و 1 مگا بیت بر ثانیه را با آپلود ست کنیم باید به صورت زیر عمل کنیم:

interface GigabitEthernet0/0.621

 encapsulation dot1Q 621

 ip address 192.168.1.1 255.255.255.0

 rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop

 rate-limit output 2048000 384000 768000 conform-action transmit exceed-action drop

پیشنهاد سیسکو برای مقادیر normal burst و max burst به صورت زیر است:

normal burst = (rate/8) * 1.5
max burst = 2 * normal burst

مثال 2

اگر بخواهیم برای نیمه بالایی آدرسهای IP در مثال قبل محدودیت 256 کیلو بیت بر ثانیه برای آپلود و 512 کیلو بیت بر ثانیه برای دانلود را نیز داشته باشیم باید به صورت زیر عمل کنیم:

ابتدا یک اکسس لیست برای مشخص کردن آدرسهای IP نیمه بالایی (آدرسهای 192.168.1.129 الی آخر) در هنگام آپلود می‌نویسیم. در هنگام آپلود این آدرسها، آدرس منبع (source IP address) بسته ها هستند. پس می‌توان آنها را با یک اکسس لیست استاندارد نیز مشخص کرد:

access-list 1 permit 192.168.1.128 0.0.0.127

سپس یک اکسس لیست دیگر برای مشخص کردن آدرسهای IP نیمه بالایی در هنگام دانلود می‌نویسیم. در هنگام دانلود این آدرسها، آدرس مقصد (destination IP address) بسته ها هستند. پس برای مشخص کردن آنها نیاز به یک اکسس لیست extended داریم:

access-list 101 permit ip any 192.168.1.128 0.0.0.127

سپس از این اکسس لیستها برای اعمال محدودیت مورد نظر بر روی sub interface مربوطه استفاده می‌کنیم.

interface GigabitEthernet0/0.621

 encapsulation dot1Q 621

 ip address 192.168.1.1 255.255.255.0

 rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop

 rate-limit output 2048000 384000 768000 conform-action transmit exceed-action drop

 rate-limit input access-group 1 256000 48000 96000 conform-action transmit exceed-action drop

 rate-limit output access-group 101 512000 96000 192000 conform-action transmit exceed-action drop

یک پاسخ

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.