Traffic Shaping

برای محدود کردن پهنای باند در مسیریابهای سیسکو می‌توان از Traffic Shaping توسط فرمان traffic-shape در مد واسط (interface) یا زیر واسطی (Subinterface) که قرار است محدودیت بر روی آن اعمال شود استفاده کرد. فرمت کامل این دستور به صورت زیر است:

traffic-shape rate bps

or

traffic-shape group acl-index bps

از traffic shape فقط برای محدود کردن پهنای باند دانلود کاربر می‌توان استفاده کرد و برای محدود کردن آپلود کاربر ناچار به استفاده از rate-limit می‌باشید.

group: اگر بخواهیم محدودیت را برای آدرسهای IP خاصی اعمال کنیم، می‌توانیم از group برای این کار استفاده کنیم. به عنوان مثال یک مشتری ممکن است دارای دو محدوده آدرس باشد و بخواهید محدودیتهای متفاوتی را برای هر یک از این دو محدوده در نظر بگیرید.

 bps: در این قسمت باید نرخ متوسط (average rate) را بر حسب بیت بر ثانیه باید نوشت.

مثال 1: اگر بخواهیم بر روی یک sub interface سرعت 2 مگا بیت در ثانیه را برای دانلود و 1 مگا بیت بر ثانیه را با آپلود ست کنیم باید به صورت زیر عمل کنیم:

interface GigabitEthernet0/0.621

 encapsulation dot1Q 621

 ip address 192.168.1.1 255.255.255.0

 rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop

 traffic-shape rate 2048000 51200 51200 1000

در فرمان traffic-shape کافیست پس از تایپ فرمان traffic-shape rate 2048000 کلید اینتر را فشار دهید. مقادیری که در بالا به صورت bold نمایش داده شده اند به صورت خودکار و توسط خود ios در نظر گرفته می‌شوند.

 

مثال 2: اگر بخواهیم برای نیمه بالایی آدرسهای IP در مثال قبل محدودیت 512 کیلو بیت بر ثانیه برای دانلود را داشته باشیم باید به صورت زیر عمل کنیم:

ابتدا باید traffic shape اعمال شده در مثال قبل را توسط فرمان no traffic-shape rate حذف کنیم. زیرا امکان اعمال traffic shape با اکسس لیست و بدون اکسس لیست ممکن نمی‌باشد. در صورت انجام این کار پیامی به صورت زیر مشاهد خواهید کرد.

mix of shaping with and without access lists prohibited

یک اکسس لیست برای مشخص کردن آدرسهای IP نیمه پایین و یک اکسس لیست برای مشخص کردن آدرسهای IP نیمه بالایی در هنگام دانلود می‌نویسیم. در هنگام دانلود این آدرسها، آدرس مقصد (destination IP address) بسته ها هستند. پس برای مشخص کردن آنها نیاز به یک اکسس لیست extended داریم:

access-list 100 permit ip any 192.168.1.0 0.0.0.127

access-list 101 permit ip any 192.168.1.128 0.0.0.127

سپس از این اکسس لیستها برای اعمال محدودیت مورد نظر بر روی sub interface مربوطه استفاده می‌کنیم.

interface GigabitEthernet0/0.621

 encapsulation dot1Q 621

 ip address 192.168.1.1 255.255.255.0

 rate-limit input 1024000 192000 384000 conform-action transmit exceed-action drop

 traffic-shape group 100 1536000 38400 38400 1000

 traffic-shape group 101 512000 12800 12800 1000

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.